summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 99447a8d3..0ecc0402d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -322,9 +322,15 @@ php4-compile: expat-compile
endif
php5-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP5_MOD_CURL),)
+php5-compile: curl-compile
+endif
ifneq ($(BR2_PACKAGE_PHP5_MOD_GD),)
php5-compile: libgd-compile libpng-compile
endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_GMP),)
+php5-compile: gmp-compile
+endif
ifneq ($(BR2_PACKAGE_PHP5_MOD_LDAP),)
php5-compile: openldap-compile
endif