summaryrefslogtreecommitdiffstats
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-19 23:11:06 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-19 23:11:06 +0000
commitd852d33252c18830bfeee748f8a170339e2853da (patch)
tree931c0e90f5f485ced9604763b70ca21c927ebfd8 /openwrt/package/Makefile
parentbc7f04c1b407c70a283fa63d463be2d1981bef30 (diff)
update to new upstream release (v5.0.5),
enable all packages when DEVELOPER=1, add curl and gmp extensions, fix gd extension build git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1950 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 99447a8d3..0ecc0402d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -322,9 +322,15 @@ php4-compile: expat-compile
endif
php5-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP5_MOD_CURL),)
+php5-compile: curl-compile
+endif
ifneq ($(BR2_PACKAGE_PHP5_MOD_GD),)
php5-compile: libgd-compile libpng-compile
endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_GMP),)
+php5-compile: gmp-compile
+endif
ifneq ($(BR2_PACKAGE_PHP5_MOD_LDAP),)
php5-compile: openldap-compile
endif