summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-16 22:26:21 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-16 22:26:21 +0000
commit97ab85558cf2357af8caf074594a348c188ea26f (patch)
tree274aa7759aed6f5da634f3864f697d37cf2a221e /openwrt/package
parent56ccdab3fd592f5bbd4f29b5adfbefd9f6fa7aff (diff)
Create iptraf directories
Build mod_webdav for lighttpd Fix libtool patch git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3661 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/depend.mk2
-rw-r--r--openwrt/package/iptraf/Makefile4
-rw-r--r--openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch15
-rw-r--r--openwrt/package/lighttpd/Makefile5
-rw-r--r--openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control5
-rw-r--r--openwrt/package/lighttpd/patches/501-libxml2_includes.patch12
6 files changed, 40 insertions, 3 deletions
diff --git a/openwrt/package/depend.mk b/openwrt/package/depend.mk
index c9f7157cb..043e637d6 100644
--- a/openwrt/package/depend.mk
+++ b/openwrt/package/depend.mk
@@ -42,7 +42,7 @@ libnids-compile: libnet-compile
libvorbis-compile: libogg-compile
libxml2-compile: zlib-compile
libxslt-compile: libxml2-compile
-lighttpd-compile: openssl-compile pcre-compile
+lighttpd-compile: openssl-compile pcre-compile libxml2-compile sqlite-compile
logrotate-compile: popt-compile
madplay-compile: libid3tag-compile libmad-compile
miax-compile: bluez-libs-compile
diff --git a/openwrt/package/iptraf/Makefile b/openwrt/package/iptraf/Makefile
index 7c46ed092..45377c604 100644
--- a/openwrt/package/iptraf/Makefile
+++ b/openwrt/package/iptraf/Makefile
@@ -36,7 +36,9 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
touch $@
$(IPKG_IPTRAF):
- install -d -m0755 $(IDIR_IPTRAF)/usr/bin
+ install -d -m0755 $(IDIR_IPTRAF)/usr/bin \
+ $(IDIR_IPTRAF)/var/run/iptraf \
+ $(IDIR_IPTRAF)/var/lib/iptraf
install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(IDIR_IPTRAF)/usr/bin/
$(RSTRIP) $(IDIR_IPTRAF)
$(IPKG_BUILD) $(IDIR_IPTRAF) $(PACKAGE_DIR)
diff --git a/openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch b/openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch
new file mode 100644
index 000000000..b75972efe
--- /dev/null
+++ b/openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch
@@ -0,0 +1,15 @@
+diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
+--- libtool-1.5.14/libltdl/acinclude.m4 2005-02-12 13:20:02.000000000 +0100
++++ libtool-1.5.14.new/libltdl/acinclude.m4 2006-04-16 11:22:03.000000000 +0200
+@@ -6228,10 +6228,9 @@
+ ;;
+ esac
+ ])
+-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
++AC_DEFUN([AC_LTDL_SYS_DLOPEN_DEPLIBS],
+ AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
+ [Define if the OS needs help to load dependent libraries for dlopen().])
+-fi
+ ])# AC_LTDL_SYS_DLOPEN_DEPLIBS
+
+
diff --git a/openwrt/package/lighttpd/Makefile b/openwrt/package/lighttpd/Makefile
index d15efe456..5b53d33a1 100644
--- a/openwrt/package/lighttpd/Makefile
+++ b/openwrt/package/lighttpd/Makefile
@@ -42,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_SIMPLE_VHOST,lighttpd-mod-simple-vhost,$
$(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_WEBDAV,lighttpd-mod-webdav,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
@@ -58,6 +59,7 @@ $(eval $(call PKG_mod_template,LIGHTTPD_MOD_SIMPLE_VHOST,simple_vhost))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SSI,ssi))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_STATUS,status))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_USERTRACK,usertrack))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_WEBDAV,webdav))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -101,7 +103,7 @@ $(PKG_BUILD_DIR)/.configured:
--with-openssl="$(STAGING_DIR)/usr" \
--with-pcre \
--without-valgrind \
- --without-webdav-props \
+ --with-webdav-props \
)
touch $@
@@ -109,6 +111,7 @@ $(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ STAGING_DIR=$(STAGING_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control
new file mode 100644
index 000000000..0d5110ce6
--- /dev/null
+++ b/openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control
@@ -0,0 +1,5 @@
+Package: lighttpd-mod-webdav
+Priority: optional
+Section: net
+Description: a webdav module for lighttpd
+Depends: lighttpd, libxml2, sqlite
diff --git a/openwrt/package/lighttpd/patches/501-libxml2_includes.patch b/openwrt/package/lighttpd/patches/501-libxml2_includes.patch
new file mode 100644
index 000000000..4b7943d9d
--- /dev/null
+++ b/openwrt/package/lighttpd/patches/501-libxml2_includes.patch
@@ -0,0 +1,12 @@
+diff -urN lighttpd-1.4.11/src/Makefile.in lighttpd-1.4.11.new/src/Makefile.in
+--- lighttpd-1.4.11/src/Makefile.in 2006-03-07 13:21:02.000000000 +0100
++++ lighttpd-1.4.11.new/src/Makefile.in 2006-04-17 00:16:12.000000000 +0200
+@@ -409,7 +409,7 @@
+ STRIP = @STRIP@
+ U = @U@
+ VERSION = @VERSION@
+-XML_CFLAGS = @XML_CFLAGS@
++XML_CFLAGS = -I$(STAGING_DIR)/usr/include/libxml2
+ XML_LIBS = @XML_LIBS@
+ Z_LIB = @Z_LIB@
+ ac_ct_AR = @ac_ct_AR@