summaryrefslogtreecommitdiffstats
path: root/openwrt/package/iptraf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/iptraf/Makefile')
-rw-r--r--openwrt/package/iptraf/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/iptraf/Makefile b/openwrt/package/iptraf/Makefile
index 7c46ed092..45377c604 100644
--- a/openwrt/package/iptraf/Makefile
+++ b/openwrt/package/iptraf/Makefile
@@ -36,7 +36,9 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
touch $@
$(IPKG_IPTRAF):
- install -d -m0755 $(IDIR_IPTRAF)/usr/bin
+ install -d -m0755 $(IDIR_IPTRAF)/usr/bin \
+ $(IDIR_IPTRAF)/var/run/iptraf \
+ $(IDIR_IPTRAF)/var/lib/iptraf
install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(IDIR_IPTRAF)/usr/bin/
$(RSTRIP) $(IDIR_IPTRAF)
$(IPKG_BUILD) $(IDIR_IPTRAF) $(PACKAGE_DIR)