summaryrefslogtreecommitdiffstats
path: root/package/openwrt/libshared/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/openwrt/libshared/Makefile')
-rw-r--r--package/openwrt/libshared/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/openwrt/libshared/Makefile b/package/openwrt/libshared/Makefile
index 601dc665c..4309c8ce6 100644
--- a/package/openwrt/libshared/Makefile
+++ b/package/openwrt/libshared/Makefile
@@ -26,12 +26,14 @@ $(PKG_BUILD_DIR):
$(PKG_BUILD_DIR)/libshared.so: $(LIBSHARED_OBJS)
$(TARGET_CC) -shared -o $@ $^
+$(STAGING_DIR)/lib/libshared.so: $(PKG_BUILD_DIR)/libshared.so
+ install -m 644 $< $@
+
$(TARGET_DIR)/usr/lib/libshared.so: $(PKG_BUILD_DIR)/libshared.so
install -m 644 $^ $@
- install -m 644 $^ $(STAGING_DIR)/lib/libshared.so
$(STRIP) $@
-compile: $(PKG_BUILD_DIR)/libshared.so
+compile: $(PKG_BUILD_DIR)/libshared.so $(STAGING_DIR)/lib/libshared.so
install: $(TARGET_DIR)/usr/lib/libshared.so
clean: