summaryrefslogtreecommitdiffstats
path: root/package/openwrt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/openwrt/Makefile')
-rw-r--r--package/openwrt/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/openwrt/Makefile b/package/openwrt/Makefile
index a5642cd4e..01c830dc4 100644
--- a/package/openwrt/Makefile
+++ b/package/openwrt/Makefile
@@ -83,6 +83,8 @@ $(PKG_BUILD_DIR)/wlcompat-debug.o:
$(PKG_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/wlcompat kmod-wlcompat.control $(LINUX_VERSION)-$(PKG_RELEASE) $(ARCH)
+ mkdir -p $(PKG_BUILD_DIR)/wlcompat/etc/modules.d
+ echo "insmod wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
mkdir -p $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)
cp $^ $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(PKG_BUILD_DIR)/wlcompat $(PACKAGE_DIR)