summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 3358f1fd9..ae557f26b 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -76,6 +76,11 @@ ifneq ($(6),)
for module in $(7); do \
echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
done
+ echo "#!/bin/sh" >> $$(I_$(1))/CONTROL/postinst
+ echo "[ -z \"\$$$$IPKG_INSTROOT\" ] || exit" >> $$(I_$(1))/CONTROL/postinst
+ echo ". /etc/functions.sh" >> $$(I_$(1))/CONTROL/postinst
+ echo "load_modules /etc/modules.d/$(6)-$(2)" >> $$(I_$(1))/CONTROL/postinst
+ chmod 0755 $$(I_$(1))/CONTROL/postinst
endif
$(8)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR) $(MAKE_TRACE)