summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/au1000-2.6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/target/linux/au1000-2.6/Makefile')
-rw-r--r--openwrt/target/linux/au1000-2.6/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/target/linux/au1000-2.6/Makefile b/openwrt/target/linux/au1000-2.6/Makefile
index 35ab1034c..4b596f603 100644
--- a/openwrt/target/linux/au1000-2.6/Makefile
+++ b/openwrt/target/linux/au1000-2.6/Makefile
@@ -17,10 +17,10 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
@$(CP) config $(LINUX_DIR)/.config
touch $@
-$(LINUX_BUILD_DIR)/zImage: $(LINUX_DIR)/vmlinux
+$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec
$(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) zImage.flash $(MAKE_TRACE)
- $(CP) $(LINUX_DIR)/vmlinux $@
- echo "toto"
+ $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
+ $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
touch $@
compile: $(LINUX_DIR)/vmlinux