summaryrefslogtreecommitdiffstats
path: root/openwrt/package/openser/patches
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/openser/patches')
-rw-r--r--openwrt/package/openser/patches/Makefile.defs.patch71
-rw-r--r--openwrt/package/openser/patches/cfg.lex.patch13
-rw-r--r--openwrt/package/openser/patches/config.h.patch33
-rw-r--r--openwrt/package/openser/patches/modules-build.patch57
-rw-r--r--openwrt/package/openser/patches/openser.cfg.patch33
-rw-r--r--openwrt/package/openser/patches/sc.dbtext.patch22
-rw-r--r--openwrt/package/openser/patches/sc.patch41
7 files changed, 0 insertions, 270 deletions
diff --git a/openwrt/package/openser/patches/Makefile.defs.patch b/openwrt/package/openser/patches/Makefile.defs.patch
deleted file mode 100644
index a7275bdd0..000000000
--- a/openwrt/package/openser/patches/Makefile.defs.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- openser-1.0.0-tls.orig/Makefile.defs 2005-10-28 18:32:39.000000000 +0200
-+++ openser-1.0.0-tls/Makefile.defs 2006-01-15 23:40:18.391547040 +0100
-@@ -917,7 +917,7 @@
- endif
- YACC_FLAGS=-d -b cfg
- # on solaris add -lxnet (e.g. LIBS= -lxnet)
--LIBS= -lfl -ldl -lresolv
-+LIBS= -ldl -lresolv
-
-
- #os specific stuff
-@@ -955,7 +955,7 @@
- endif
- OLD_SOLARIS= $(shell echo "$(OSREL)" | \
- sed -e 's/^5\.[0-6][^0-9]*$$/yes/' )
-- LIBS+= -L$(LOCALBASE)/lib -lfl -lxnet -lnsl
-+ LIBS+= -L$(LOCALBASE)/lib -lxnet -lnsl
- ifeq ($(OLD_SOLARIS), yes)
- LIBS+=-lposix4
- else
-@@ -970,9 +970,9 @@
- ifneq ($(found_lock_method), yes)
- DEFS+= -DUSE_PTHREAD_MUTEX # try pthread sems
- found_lock_method=yes
-- LIBS= -pthread -lfl #dlopen is in libc
-+ LIBS= -pthread #dlopen is in libc
- else
-- LIBS= -lfl #dlopen is in libc
-+ LIBS= #dlopen is in libc
- endif
- YACC=yacc
- endif
-@@ -987,7 +987,7 @@
- # (symbols on openbsd are prefixed by "_")
- YACC=yacc
- # no sched_yield on openbsd unless linking with c_r (not recommended)
-- LIBS= -lfl
-+ LIBS=
- OPENBSD_IS_AOUT= $(shell echo "$(OSREL)" | \
- sed -e 's/^3\.[0-3][^0-9]*$$/yes/' |sed -e 's/^[0-2]\..*/yes/')
- # exception: on sparc openbsd 3.2 is elf and not aout
-@@ -1014,7 +1014,7 @@
- found_lock_method=yes
- endif
- YACC=yacc
-- LIBS= -lfl
-+ LIBS=
- endif
-
- # OS X support, same as freebsd
-@@ -1028,9 +1028,9 @@
- ifneq ($(found_lock_method), yes)
- DEFS+= -DUSE_PTHREAD_MUTEX # try pthread sems
- found_lock_method=yes
-- LIBS= -pthread -lfl -lresolv #dlopen is in libc
-+ LIBS= -pthread -lresolv #dlopen is in libc
- else
-- LIBS= -lfl -lresolv #dlopen is in libc
-+ LIBS= -lresolv #dlopen is in libc
- endif
- LDFLAGS= # darwin doesn't like -O2 or -E
- MOD_LDFLAGS= -bundle -bundle_loader ../../$(MAIN_NAME)
-@@ -1047,7 +1047,7 @@
-
- #add libssl if needed
- ifneq ($(TLS),)
--DEFS+= -I$(LOCALBASE)/ssl/include
-+DEFS+= -I$(LOCALBASE)/include
- LIBS+= -L$(LOCALBASE)/lib -L$(LOCALBASE)/ssl/lib -lssl -lcrypto
- endif
-
diff --git a/openwrt/package/openser/patches/cfg.lex.patch b/openwrt/package/openser/patches/cfg.lex.patch
deleted file mode 100644
index 39eacb2de..000000000
--- a/openwrt/package/openser/patches/cfg.lex.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- openser-1.0.0-tls.orig/cfg.lex 2005-09-02 17:34:41.000000000 +0200
-+++ openser-1.0.0-tls/cfg.lex 2006-01-05 01:34:50.279630928 +0100
-@@ -85,6 +85,10 @@
- static char* addstr(struct str_buf *, char*, int);
- static void count();
-
-+ int yywrap(void)
-+ {
-+ return 1;
-+ }
-
- %}
-
diff --git a/openwrt/package/openser/patches/config.h.patch b/openwrt/package/openser/patches/config.h.patch
deleted file mode 100644
index 45af8f1f7..000000000
--- a/openwrt/package/openser/patches/config.h.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- openser-1.0.0-tls.orig/config.h 2005-08-23 19:31:12.000000000 +0200
-+++ openser-1.0.0-tls/config.h 2006-01-05 01:42:14.101159800 +0100
-@@ -48,7 +48,7 @@
- #define MAX_LISTEN 16
-
- /* default number of child processes started */
--#define CHILD_NO 8
-+#define CHILD_NO 4
-
- #define RT_NO 40 /* routing tables number */
- #define FAILURE_RT_NO RT_NO /* on_failure routing tables number */
-@@ -68,10 +68,10 @@
- #define CONTENT_LENGTH "Content-Length: "
- #define CONTENT_LENGTH_LEN (sizeof(CONTENT_LENGTH)-1)
-
--#define USER_AGENT "User-Agent: OpenSer (" VERSION " (" ARCH "/" OS"))"
-+#define USER_AGENT "User-Agent: OpenSer " VERSION " (boozy.milkfish.org)"
- #define USER_AGENT_LEN (sizeof(USER_AGENT)-1)
-
--#define SERVER_HDR "Server: OpenSer (" VERSION " (" ARCH "/" OS"))"
-+#define SERVER_HDR "Server: OpenSer " VERSION " (boozy.milkfish.org)"
- #define SERVER_HDR_LEN (sizeof(SERVER_HDR)-1)
-
- #define MAX_WARNING_LEN 256
-@@ -113,7 +113,7 @@
- #define PKG_MEM_POOL_SIZE 1024*1024
-
- /*used if SH_MEM is defined*/
--#define SHM_MEM_SIZE 32
-+#define SHM_MEM_SIZE 8
-
- #define TIMER_TICK 1
-
diff --git a/openwrt/package/openser/patches/modules-build.patch b/openwrt/package/openser/patches/modules-build.patch
deleted file mode 100644
index 6e6ee00c4..000000000
--- a/openwrt/package/openser/patches/modules-build.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- openser-1.0.1/Makefile 2006-02-15 20:52:21.000000000 +0100
-+++ openser-1.0.1.new/Makefile 2006-03-17 11:01:27.417488936 +0100
-@@ -46,8 +46,7 @@
- skip_modules?=
-
- # if not set on the cmd. line or the env, exclude this modules:
--exclude_modules?= jabber cpl-c pa postgres mysql \
-- avp_radius auth_radius group_radius uri_radius
-+exclude_modules?= jabber cpl-c pa
- # always exclude the CVS dir
- override exclude_modules+= CVS $(skip_modules)
-
-diff -urN openser-1.0.1/modules/acc/Makefile openser-1.0.1.new/modules/acc/Makefile
---- openser-1.0.1/modules/acc/Makefile 2005-09-05 21:32:02.000000000 +0200
-+++ openser-1.0.1.new/modules/acc/Makefile 2006-03-17 10:38:14.333269928 +0100
-@@ -14,8 +14,8 @@
- DEFS+=-DSQL_ACC
-
- # uncomment the next two lines if you wish to enable RADIUS accounting
--#DEFS+=-DRAD_ACC -I$(LOCALBASE)/include
--#LIBS=-L$(LOCALBASE)/lib -lradiusclient-ng
-+DEFS+=-DRAD_ACC -I$(LOCALBASE)/include
-+LIBS=-L$(LOCALBASE)/lib -lradiusclient-ng
-
- # uncomment the next two lines if you wish to enable DIAMETER accounting
- #DEFS+=-DDIAM_ACC
-diff -urN openser-1.0.1/modules/mysql/Makefile openser-1.0.1.new/modules/mysql/Makefile
---- openser-1.0.1/modules/mysql/Makefile 2005-06-13 18:47:40.000000000 +0200
-+++ openser-1.0.1.new/modules/mysql/Makefile 2006-03-17 11:12:16.218856136 +0100
-@@ -9,14 +9,12 @@
- # mysql.h locations (freebsd,openbsd solaris)
- DEFS +=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/mysql \
- -I$(LOCALBASE)/mysql/include \
-- -I/usr/include/mysql
-
- # libmysqlclient locations on RH/Suse, Solaris /OpenBSD, FreeBSD
- # (Debian does the right thing and puts it in /usr/lib)
- LIBS=-L/usr/lib/mysql -L$(LOCALBASE)/lib -L$(LOCALBASE)/lib/mysql \
- -L$(LOCALBASE)/mysql/lib/mysql/ \
- -L$(LOCALBASE)/mysql/lib \
-- -L/usr/lib64/mysql \
- -lmysqlclient -lz
-
- include ../../Makefile.modules
-diff -urN openser-1.0.1/modules/postgres/Makefile openser-1.0.1.new/modules/postgres/Makefile
---- openser-1.0.1/modules/postgres/Makefile 2005-07-01 16:52:34.000000000 +0200
-+++ openser-1.0.1.new/modules/postgres/Makefile 2006-03-17 11:13:22.150832952 +0100
-@@ -7,8 +7,7 @@
- NAME=postgres.so
-
- # libpq-fe.h locations
--DEFS +=-I$(LOCALBASE)/include -I$(LOCALBASE)/pgsql/include \
-- -I/usr/include/postgresql -I/usr/include/postgresql/8.0
-+DEFS +=-I$(LOCALBASE)/include -I$(LOCALBASE)/pgsql/include -I$(LOCALBASE)/include/postgresql
- LIBS=-L$(LOCALBASE)/lib -L$(LOCALBASE)/pgsql/lib -L$(LOCALBASE)/lib/pgsql \
- -lpq
-
diff --git a/openwrt/package/openser/patches/openser.cfg.patch b/openwrt/package/openser/patches/openser.cfg.patch
deleted file mode 100644
index f26e79e73..000000000
--- a/openwrt/package/openser/patches/openser.cfg.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- openser-1.0.0-tls.orig/etc/openser.cfg 2005-10-28 21:45:33.000000000 +0200
-+++ openser-1.0.0-tls/etc/openser.cfg 2006-01-07 01:39:01.077134312 +0100
-@@ -36,20 +36,20 @@
- # ------------------ module loading ----------------------------------
-
- # Uncomment this if you want to use SQL database
--#loadmodule "/usr/local/lib/openser/modules/mysql.so"
-+#loadmodule "/usr/lib/openser/modules/mysql.so"
-
--loadmodule "/usr/local/lib/openser/modules/sl.so"
--loadmodule "/usr/local/lib/openser/modules/tm.so"
--loadmodule "/usr/local/lib/openser/modules/rr.so"
--loadmodule "/usr/local/lib/openser/modules/maxfwd.so"
--loadmodule "/usr/local/lib/openser/modules/usrloc.so"
--loadmodule "/usr/local/lib/openser/modules/registrar.so"
--loadmodule "/usr/local/lib/openser/modules/textops.so"
-+loadmodule "/usr/lib/openser/modules/sl.so"
-+loadmodule "/usr/lib/openser/modules/tm.so"
-+loadmodule "/usr/lib/openser/modules/rr.so"
-+loadmodule "/usr/lib/openser/modules/maxfwd.so"
-+loadmodule "/usr/lib/openser/modules/usrloc.so"
-+loadmodule "/usr/lib/openser/modules/registrar.so"
-+loadmodule "/usr/lib/openser/modules/textops.so"
-
- # Uncomment this if you want digest authentication
- # mysql.so must be loaded !
--#loadmodule "/usr/local/lib/openser/modules/auth.so"
--#loadmodule "/usr/local/lib/openser/modules/auth_db.so"
-+#loadmodule "/usr/lib/openser/modules/auth.so"
-+#loadmodule "/usr/lib/openser/modules/auth_db.so"
-
- # ----------------- setting module-specific parameters ---------------
-
diff --git a/openwrt/package/openser/patches/sc.dbtext.patch b/openwrt/package/openser/patches/sc.dbtext.patch
deleted file mode 100644
index 2a1b7eab1..000000000
--- a/openwrt/package/openser/patches/sc.dbtext.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- openser-1.0.0-tls.orig/scripts/sc.dbtext 2005-07-29 21:05:36.000000000 +0200
-+++ openser-1.0.0-tls/scripts/sc.dbtext 2006-01-29 02:30:31.795349688 +0100
-@@ -62,6 +62,10 @@
- ##### ----------------------------------------------- #####
- #### table names
-
-+if [ -z "$SIP_DOMAIN" ] ; then
-+ SIP_DOMAIN=$(nvram get sip_domain)
-+fi
-+
- # UsrLoc Table
- if [ -z "$UL_TABLE" ] ; then
- UL_TABLE=location
-@@ -247,7 +251,7 @@
- fi
-
- if [ -z "$SERDOMAIN" ] ; then
-- echo -e "\nDomain unknown: use usernames with domain or set default domain in SIP_DOMAIN\n"
-+ echo -e "\nDomain unknown: use usernames with domain or set default domain in SIP_DOMAIN (with 'nvram set sip_domain=YOUR_SIP_DOMAIN')\n"
- exit 1
- fi
- }
diff --git a/openwrt/package/openser/patches/sc.patch b/openwrt/package/openser/patches/sc.patch
deleted file mode 100644
index 52ef9a655..000000000
--- a/openwrt/package/openser/patches/sc.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- openser-1.0.0-tls.orig/scripts/sc 2005-08-11 14:08:02.000000000 +0200
-+++ openser-1.0.0-tls/scripts/sc 2006-01-29 02:18:43.319054456 +0100
-@@ -48,11 +48,15 @@
- STARTOPTIONS= # for example -dddd
- fi
- if [ -z "$DIR" ] ; then
-- DIR=`dirname $0`
-+ DIR=/usr/sbin
- fi
- if [ -z "$SERBIN" ] ; then
- SERBIN=$DIR/openser
- fi
-+if [ -z "$SIP_DOMAIN" ] ; then
-+ SIP_DOMAIN=$(nvram get sip_domain)
-+fi
-+
-
- ##### ----------------------------------------------- #####
- ### openser's FIFO server
-@@ -415,7 +419,7 @@
- fi
-
- if [ -z "$SERDOMAIN" ] ; then
-- echo "domain unknown: use usernames with domain or set default domain in SIP_DOMAIN"
-+ echo "domain unknown: use usernames with domain or set default domain in SIP_DOMAIN (with 'nvram set sip_domain=YOUR_SIP_DOMAIN')"
- exit 1
- fi
- }
-@@ -671,11 +675,7 @@
- set_user $2
- fifo_cmd ul_show_contact $USRLOC_TABLE "$SERUSER@$SERDOMAIN"
- elif [ $# -eq 1 ] ; then
-- printf "Dumping all contacts may take long: are you sure you want to proceed? [Y|N] " > /dev/stderr
-- read answer
-- if [ "$answer" = "y" -o "$answer" = "Y" ] ; then
-- fifo_cmd ul_dump
-- fi
-+ fifo_cmd ul_dump
- else
- echo "wrong number of params for usrloc show"
- usage