summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2011-03-18 13:40:48 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2011-03-18 13:40:48 +0000
commitcdb411af996a3620dc674e5314f3b499385a0650 (patch)
treefc03176ff0d31c934b0a2e41b9fff6b1683837fd /target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
parent6cd2a38d9443178b42f390440413d91d5984a04c (diff)
remove 2.6.34 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26229 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch')
-rw-r--r--target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch b/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
deleted file mode 100644
index 63834d65e..000000000
--- a/target/linux/generic/patches-2.6.34/998-openwrt_lzma_options.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -238,7 +238,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
-
- quiet_cmd_lzma = LZMA $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
-- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+ lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
- (rm -f $@ ; false)
-
- quiet_cmd_lzo = LZO $@
---- a/scripts/gen_initramfs_list.sh
-+++ b/scripts/gen_initramfs_list.sh
-@@ -225,7 +225,7 @@ cpio_list=
- output="/dev/stdout"
- output_file=""
- is_cpio_compressed=
--compr="gzip -9 -f"
-+compr="gzip -9 -f -"
-
- arg="$1"
- case "$arg" in
-@@ -239,9 +239,9 @@ case "$arg" in
- output_file="$1"
- cpio_list="$(mktemp ${TMPDIR:-/tmp}/cpiolist.XXXXXX)"
- output=${cpio_list}
-- echo "$output_file" | grep -q "\.gz$" && compr="gzip -9 -f"
-- echo "$output_file" | grep -q "\.bz2$" && compr="bzip2 -9 -f"
-- echo "$output_file" | grep -q "\.lzma$" && compr="lzma -9 -f"
-+ echo "$output_file" | grep -q "\.gz$" && compr="gzip -9 -f -"
-+ echo "$output_file" | grep -q "\.bz2$" && compr="bzip2 -9 -f -"
-+ echo "$output_file" | grep -q "\.lzma$" && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
- echo "$output_file" | grep -q "\.cpio$" && compr="cat"
- shift
- ;;
-@@ -292,7 +292,7 @@ if [ ! -z ${output_file} ]; then
- if [ "${is_cpio_compressed}" = "compressed" ]; then
- cat ${cpio_tfile} > ${output_file}
- else
-- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
-+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
- || (rm -f ${output_file} ; false)
- fi
- [ -z ${cpio_file} ] && rm ${cpio_tfile}
---- a/lib/decompress.c
-+++ b/lib/decompress.c
-@@ -36,6 +36,7 @@ static const struct compress_format {
- { {037, 0236}, "gzip", gunzip },
- { {0x42, 0x5a}, "bzip2", bunzip2 },
- { {0x5d, 0x00}, "lzma", unlzma },
-+ { {0x6d, 0x00}, "lzma-openwrt", unlzma },
- { {0x89, 0x4c}, "lzo", unlzo },
- { {0, 0}, NULL, NULL }
- };