summaryrefslogtreecommitdiffstats
path: root/package/iproute2/patches/000-debian_patches_3.patch
diff options
context:
space:
mode:
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2010-12-02 20:29:22 +0000
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2010-12-02 20:29:22 +0000
commitfab3a85d30350bbaa65e938f39b66e06e614af22 (patch)
tree80dba4c33638060a979fd39a345ae83f532d23a6 /package/iproute2/patches/000-debian_patches_3.patch
parentdb07bdac3e8af612806c4cd7d4a4e46315d9ac4b (diff)
[package] iproute2: dont filter cached routes on iproute_get (#8339)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24216 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2/patches/000-debian_patches_3.patch')
-rw-r--r--package/iproute2/patches/000-debian_patches_3.patch42
1 files changed, 21 insertions, 21 deletions
diff --git a/package/iproute2/patches/000-debian_patches_3.patch b/package/iproute2/patches/000-debian_patches_3.patch
index 3c2debc1a..8e688f89c 100644
--- a/package/iproute2/patches/000-debian_patches_3.patch
+++ b/package/iproute2/patches/000-debian_patches_3.patch
@@ -10,8 +10,8 @@
tc/q_wrr.c | 322 ++++++++++++++++++++++++++++
9 files changed, 1177 insertions(+), 5 deletions(-)
---- iproute2-2.6.35.orig/doc/ip-cref.tex
-+++ iproute2-2.6.35/doc/ip-cref.tex
+--- a/doc/ip-cref.tex
++++ b/doc/ip-cref.tex
@@ -1307,6 +1307,19 @@ peers are allowed to send to us.
--- \threeonly the clamp for congestion window. It is ignored if the \verb|lock|
flag is not used.
@@ -32,18 +32,18 @@
\item \verb|advmss NUMBER|
-@@ -2664,6 +2677,9 @@ http://www.cisco.com/univercd/cc/td/doc/
-
+@@ -2665,6 +2678,9 @@ http://www.cisco.com/univercd/cc/td/doc/
\bibitem{RFC2414} M.~Allman, S.~Floyd, C.~Partridge.
``Increasing TCP's Initial Window'', RFC-2414.
-+
+
+\bibitem{RFC2414} M.~Allman, S.~Floyd, C.~Partridge.
+``Increasing TCP's Initial Window'', RFC-2414.
-
++
\end{thebibliography}
---- iproute2-2.6.35.orig/doc/Makefile
-+++ iproute2-2.6.35/doc/Makefile
+
+--- a/doc/Makefile
++++ b/doc/Makefile
@@ -14,6 +14,7 @@ PAGESIZE=a4
PAGESPERPAGE=2
@@ -75,8 +75,8 @@
clean:
- rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html
+ rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html $(TXTFILES)
---- iproute2-2.6.35.orig/include/linux/pkt_sched.h
-+++ iproute2-2.6.35/include/linux/pkt_sched.h
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
@@ -1,3 +1,409 @@
+#if 0
+#ifndef __LINUX_PKT_SCHED_H
@@ -604,8 +604,8 @@
+};
+
#endif
---- iproute2-2.6.35.orig/ip/iptunnel.c
-+++ iproute2-2.6.35/ip/iptunnel.c
+--- a/ip/iptunnel.c
++++ b/ip/iptunnel.c
@@ -130,7 +130,7 @@ static int parse_args(int argc, char **a
NEXT_ARG();
p->o_flags |= GRE_KEY;
@@ -615,8 +615,8 @@
else {
if (get_unsigned(&uval, *argv, 0)<0) {
fprintf(stderr, "invalid value of \"okey\"\n");
---- iproute2-2.6.35.orig/Makefile
-+++ iproute2-2.6.35/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -57,7 +57,7 @@ install: all
$(DESTDIR)$(DOCDIR)/examples
install -m 0644 $(shell find examples/diffserv -maxdepth 1 -type f) \
@@ -635,8 +635,8 @@
do $(MAKE) $(MFLAGS) -C $$i clean; done
clobber: clean
---- iproute2-2.6.35.orig/misc/Makefile
-+++ iproute2-2.6.35/misc/Makefile
+--- a/misc/Makefile
++++ b/misc/Makefile
@@ -1,7 +1,8 @@
SSOBJ=ss.o ssfilter.o
LNSTATOBJ=lnstat.o lnstat_util.o
@@ -647,8 +647,8 @@
include ../Config
---- iproute2-2.6.35.orig/tc/Makefile
-+++ iproute2-2.6.35/tc/Makefile
+--- a/tc/Makefile
++++ b/tc/Makefile
@@ -15,6 +15,7 @@ TCMODULES += q_cbq.o
TCMODULES += q_rr.o
TCMODULES += q_multiq.o
@@ -657,8 +657,8 @@
TCMODULES += f_rsvp.o
TCMODULES += f_u32.o
TCMODULES += f_route.o
---- iproute2-2.6.35.orig/tc/q_htb.c
-+++ iproute2-2.6.35/tc/q_htb.c
+--- a/tc/q_htb.c
++++ b/tc/q_htb.c
@@ -1,3 +1,311 @@
+#if 0
+/*
@@ -972,7 +972,7 @@
* q_htb.c HTB.
*
--- /dev/null
-+++ iproute2-2.6.35/tc/q_wrr.c
++++ b/tc/q_wrr.c
@@ -0,0 +1,322 @@
+#include <stdio.h>
+#include <stdlib.h>