summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-13 07:33:34 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-13 07:33:34 +0000
commitacf3e1645dd0bb38179296f0cd6ff1303622326a (patch)
tree4d9adc44c978227ad79424739a5f91a74043b25c /openwrt
parent713b572fec767f2fc65fc519890d1d9d4f0d0cb7 (diff)
build jffs2 image too since it works with CF and MTD block emulation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1618 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/soekris/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/soekris/Makefile b/openwrt/target/linux/image/soekris/Makefile
index bfb2770ef..0b4fba9d8 100644
--- a/openwrt/target/linux/image/soekris/Makefile
+++ b/openwrt/target/linux/image/soekris/Makefile
@@ -2,9 +2,32 @@ include $(TOPDIR)/rules.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/rootfs.tar.gz
+
+ifeq ($(FS),jffs2-8MB)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
cp $^ $@
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+
+endif
+
+
+ifeq ($(FS),tgz)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
+ cp $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+
+endif
+
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/bzImage
+ cp $^ $@
+
+
prepare:
compile:
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+