summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-03-20 18:32:11 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-03-20 18:32:11 +0000
commit97c3fc5248dafda5ac2a11552e25e5d015d46e4d (patch)
tree6b142846e3abbe4b87dc8af2a44092a5035ee8f3 /openwrt
parent7ede0a854cc1995c7e66947bd42f5616863c7f72 (diff)
fix motion package
aka - clean up someone elses's mess git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3419 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/motion/Makefile12
2 files changed, 7 insertions, 7 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index eaf9bf43c..049a47a99 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -439,7 +439,7 @@ mini_httpd-compile: openssl-compile
endif
ifneq ($(BR2_PACKAGE_MOTION),)
-motion-compile: libjpeg-compile
+motion-compile: jpeg-compile
endif
ifneq ($(BR2_PACKAGE_MPD_MP3),)
diff --git a/openwrt/package/motion/Makefile b/openwrt/package/motion/Makefile
index 578d35be1..1cc30398e 100644
--- a/openwrt/package/motion/Makefile
+++ b/openwrt/package/motion/Makefile
@@ -35,15 +35,15 @@ $(PKG_BUILD_DIR)/.built:
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
- install_prefix="$(PKG_INSTALL_DIR)" \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@
-$(IPKG_FOO):
- install -d -m0755 $(IDIR_FOO)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/motion $(IDIR_FOO)/usr/sbin
- $(RSTRIP) $(IDIR_FOO)
- $(IPKG_BUILD) $(IDIR_FOO) $(PACKAGE_DIR)
+$(IPKG_MOTION):
+ install -d -m0755 $(IDIR_MOTION)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/motion $(IDIR_MOTION)/usr/bin
+ $(RSTRIP) $(IDIR_MOTION)
+ $(IPKG_BUILD) $(IDIR_MOTION) $(PACKAGE_DIR)
mostlyclean:
make -C $(PKG_BUILD_DIR) clean