summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-13 16:15:24 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-13 16:15:24 +0000
commit7e7df36ee8b78654b72045c2100a8cb9f03a58e3 (patch)
tree242ef7b1c29a2792defcd20b5d7553f6a3a852a7 /openwrt
parent86807fb071ee720e050ff3edf8a65f642d6f3a10 (diff)
fix tgz building
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1632 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/tgz.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/target/linux/image/tgz.mk b/openwrt/target/linux/image/tgz.mk
index 544aeae5c..756d28b6a 100644
--- a/openwrt/target/linux/image/tgz.mk
+++ b/openwrt/target/linux/image/tgz.mk
@@ -1,9 +1,14 @@
$(KDIR)/root.tar.gz:
tar -zcf $@ --owner=root --group=root -C $(KDIR)/root/ .
+ifeq ($(BOARD),soekris)
+install: tgz-install
+
tgz-install: $(KDIR)/root.tar.gz
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="tgz"
+endif
prepare:
compile:
-install: tgz-install
+install: $(KDIR)/root.tar.gz
+