summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-29 10:47:33 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-29 10:47:33 +0000
commit4f99a13308237667eed1572faec096451924077e (patch)
tree89b52e0d28c43c08ef95ba7214343a266d48d79d /openwrt
parentd61faa0500f91f43858f8455fd0f160458ee6a35 (diff)
make a image for netgear, loader need to be ELF
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1784 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/image/brcm/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index c0c83c52f..09f2d1429 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -27,6 +27,15 @@ endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
$(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+ifeq ($(KERNEL),2.6)
+FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+
+$(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ dd if=$(BUILD_DIR)/loader-0.04/loader.o of=$@ bs=65536 conv=sync
+ cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
+
+install: $(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin
+endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))