summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-10 15:06:24 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-10 15:06:24 +0000
commit4892ba62ef784a9b300045dad2a803b611196d6f (patch)
tree8d3b1a8c24796fae96adf155c9da27ec5f0ae16a /openwrt
parentecfd7bce7770f4242ab4526e31d70d4f78813966 (diff)
Add some missing headers to STAGING_DIR, required to build php4 extension
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1399 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index de021ba35..1f37bb752 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -95,6 +95,7 @@ $(IPKG_PGSQL_CLI):
$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
@@ -106,6 +107,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
uninstall-dev:
rm -rf \
+ $(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \