summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-30 21:53:25 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-30 21:53:25 +0000
commit39ff92136c3f204c48cb05ffd021ee84a8879a0c (patch)
treed48c5fac06b42bce14887ccddf5b544eb6df697e /openwrt
parent5606d99dae14e010d9e07d1bab940d1ea95ea391 (diff)
fix for adding files to image builder make
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/imagebuilder/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/target/linux/imagebuilder/Makefile b/openwrt/target/linux/imagebuilder/Makefile
index 95b0939c4..c70fb11e9 100644
--- a/openwrt/target/linux/imagebuilder/Makefile
+++ b/openwrt/target/linux/imagebuilder/Makefile
@@ -40,9 +40,9 @@ build:
$(IPKG_KERNEL) install `ls packages/$${package}_*`; \
done
if [ -d ./files ]; then \
- cp -fpR ./files/* $(LINUX_BUILD_DIR)/root; \
+ cp -a --remove-destination ./files/* $(LINUX_BUILD_DIR)/root; \
fi
if [ -d ./files.$(LIST) ]; then \
- cp -fpR ./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
+ cp -a --remove-destination ./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
fi
$(MAKE) -S -C image KERNEL="$(KERNEL)" BOARD="$(BOARD)" BIN_DIR="$(BIN_DIR)/$(LIST)" install