summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-21 22:19:21 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-21 22:19:21 +0000
commit3887158a8ad9f505c32249873c89e1fbe4487c4d (patch)
tree9e6adfe942098091580717edcd5532fa9c36bf16 /openwrt
parenta12c7a8ffe31058bad020f6fb2342222e806dfc8 (diff)
move modules.d stuff in /etc/init.d/S10boot and make it more like /etc/modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@703 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/openwrt/Makefile2
-rwxr-xr-xopenwrt/target/default/target_skeleton/etc/init.d/S10boot2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/openwrt/Makefile b/openwrt/package/openwrt/Makefile
index 01c830dc4..ea2bfd858 100644
--- a/openwrt/package/openwrt/Makefile
+++ b/openwrt/package/openwrt/Makefile
@@ -84,7 +84,7 @@ $(PKG_BUILD_DIR)/wlcompat-debug.o:
$(PKG_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/wlcompat kmod-wlcompat.control $(LINUX_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(PKG_BUILD_DIR)/wlcompat/etc/modules.d
- echo "insmod wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
+ echo "wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
mkdir -p $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)
cp $^ $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(PKG_BUILD_DIR)/wlcompat $(PACKAGE_DIR)
diff --git a/openwrt/target/default/target_skeleton/etc/init.d/S10boot b/openwrt/target/default/target_skeleton/etc/init.d/S10boot
index 990480798..47a255dd0 100755
--- a/openwrt/target/default/target_skeleton/etc/init.d/S10boot
+++ b/openwrt/target/default/target_skeleton/etc/init.d/S10boot
@@ -25,7 +25,7 @@ touch /var/log/lastlog
}
}
-sed 's/^[^#]/insmod &/' /etc/modules 2>&-|ash
+cat /etc/modules /etc/modules.d/* | sed 's/^[^#]/insmod &/' 2>&-|ash
ifconfig lo 127.0.0.1 up
ifconfig eth0 promisc