summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 10:49:51 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 10:49:51 +0000
commit27f5f541074af5256d149e4c85c55a4df53be93e (patch)
treeb90240aa1f26adf003484a3be5a3a635c4e52302 /openwrt
parent25768f1c4d22195764ef1e818d25d2b14f95bb97 (diff)
fix dependency bug in wireless-tools makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2223 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/wireless-tools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/wireless-tools/Makefile b/openwrt/package/wireless-tools/Makefile
index b9cbbde1b..c4767b212 100644
--- a/openwrt/package/wireless-tools/Makefile
+++ b/openwrt/package/wireless-tools/Makefile
@@ -41,7 +41,7 @@ $(IPKG_WIRELESS_TOOLS):
$(RSTRIP) $(IDIR_WIRELESS_TOOLS)
$(IPKG_BUILD) $(IDIR_WIRELESS_TOOLS) $(PACKAGE_DIR)
-install-dev:
+install-dev: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/{lib,include}
cp -a $(PKG_BUILD_DIR)/libiw.so* $(STAGING_DIR)/usr/lib/
ln -sf libiw.so.28 $(STAGING_DIR)/usr/lib/libiw.so
@@ -51,5 +51,5 @@ uninstall-dev:
rm -f $(STAGING_DIR)/usr/lib/libiw.*
rm -f $(STAGING_DIR)/usr/include/{iwlib,wireless}.h
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev