summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-24 23:45:28 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-24 23:45:28 +0000
commit17538be9035e7a4f455fbb21fff5d51fb8f024b1 (patch)
treee2fb7e4ad21780aeee9972d1e3f3bbdce89def9e /openwrt
parent6560ebb671bafd823d8fed6364d015767aab5edf (diff)
add support for multiple target arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1543 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 8305f9c26..5b6c71df3 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -188,7 +188,7 @@ $(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched
-cp $(LINUX_KCONFIG) $(LINUX_DIR)/.config
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" \
$(LINUX_DIR)/Makefile \
- $(LINUX_DIR)/arch/mips/Makefile
+ $(LINUX_DIR)/arch/*/Makefile
$(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile
$(MAKE) -C $(LINUX_DIR) ARCH=$(LINUX_KARCH) oldconfig include/linux/version.h
touch $(LINUX_DIR)/.configured