summaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-10 19:42:54 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-10 19:42:54 +0000
commit02cccb3a8c2a99dd3f6b73ed8d675e96845f2534 (patch)
treee681ab8835c1cccbbabae320a821fde87cd0854c /openwrt
parenta496658829c7377f1166e9efa82759e41f4e9b47 (diff)
fix path to mysql libraries
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@612 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/asterisk/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/asterisk/Makefile b/openwrt/package/asterisk/Makefile
index 169e3915d..6326799ff 100644
--- a/openwrt/package/asterisk/Makefile
+++ b/openwrt/package/asterisk/Makefile
@@ -89,7 +89,7 @@ asterisk-compile: $(PKG_BUILD_DIR)/.patched
OPTIMIZE="$(TARGET_CFLAGS)" \
PROC="$(ARCH)" \
CFLAGS_EXTRA="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS_EXTRA="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/mysql" \
+ LDFLAGS_EXTRA="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib/mysql" \
CRYPTO_LIBS="-L$(STAGING_DIR)/usr/lib -Wl,-Bstatic -lssl -lcrypto -Wl,-Bdynamic" \
EXTRA_APPS="$(APPS)" \
EXTRA_MODS="$(MODS)" \
@@ -167,6 +167,8 @@ $(PKG_SOUNDS): asterisk-compile
$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_SOUNDS_DIR) control/$(PKG_NAME)-sounds.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(PKG_SOUNDS_DIR)/usr/lib/asterisk/sounds
cp -a $(PKG_BUILD_DIR)/sounds/* $(PKG_SOUNDS_DIR)/usr/lib/asterisk/sounds/
+ rm -f $(PKG_SOUNDS_DIR)/usr/lib/asterisk/sounds/*.mp3
+ rm -f $(PKG_SOUNDS_DIR)/usr/lib/asterisk/sounds/vm-*
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(PKG_SOUNDS_DIR) $(PACKAGE_DIR)