summaryrefslogtreecommitdiffstats
path: root/openwrt/toolchain/uClibc
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-21 23:39:26 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-21 23:39:26 +0000
commit57d4dcc803a71589ee990c79317fa6b49461e9ba (patch)
tree3d8a07a8e2642f4e394a91ce8e1cb3036267cf72 /openwrt/toolchain/uClibc
parent6c15a6272358b67fcc1c34971be58608da0659a9 (diff)
make uclibc a bit smaller
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2219 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/toolchain/uClibc')
-rw-r--r--openwrt/toolchain/uClibc/files/config.i3862
-rw-r--r--openwrt/toolchain/uClibc/files/config.mipsel2
-rw-r--r--openwrt/toolchain/uClibc/patches/120-more_standard_math.patch12
3 files changed, 14 insertions, 2 deletions
diff --git a/openwrt/toolchain/uClibc/files/config.i386 b/openwrt/toolchain/uClibc/files/config.i386
index c76d946f1..b1a9ec3a1 100644
--- a/openwrt/toolchain/uClibc/files/config.i386
+++ b/openwrt/toolchain/uClibc/files/config.i386
@@ -57,7 +57,7 @@ ARCH_LITTLE_ENDIAN=y
ARCH_HAS_MMU=y
UCLIBC_HAS_FLOATS=y
HAS_FPU=y
-DO_C99_MATH=y
+# DO_C99_MATH is not set
KERNEL_SOURCE="./toolchain_build_i386/linux"
C_SYMBOL_PREFIX=""
HAVE_DOT_CONFIG=y
diff --git a/openwrt/toolchain/uClibc/files/config.mipsel b/openwrt/toolchain/uClibc/files/config.mipsel
index 8c9444778..0c756b5f5 100644
--- a/openwrt/toolchain/uClibc/files/config.mipsel
+++ b/openwrt/toolchain/uClibc/files/config.mipsel
@@ -42,7 +42,7 @@ ARCH_LITTLE_ENDIAN=y
ARCH_HAS_MMU=y
UCLIBC_HAS_FLOATS=y
HAS_FPU=y
-DO_C99_MATH=y
+# DO_C99_MATH is not set
KERNEL_SOURCE="./toolchain_build_mipsel/linux"
C_SYMBOL_PREFIX=""
HAVE_DOT_CONFIG=y
diff --git a/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch b/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch
new file mode 100644
index 000000000..f7d626ac0
--- /dev/null
+++ b/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch
@@ -0,0 +1,12 @@
+diff -urN uClibc.old/libm/Makefile uClibc.dev/libm/Makefile
+--- uClibc.old/libm/Makefile 2005-08-18 00:49:41.000000000 +0200
++++ uClibc.dev/libm/Makefile 2005-10-22 00:56:03.106683500 +0200
+@@ -81,6 +81,8 @@
+ w_cosh.c w_exp.c s_fabs.c s_floor.c w_fmod.c s_frexp.c \
+ s_ldexp.c w_log.c w_log10.c s_modf.c w_pow.c s_sin.c \
+ w_sinh.c w_sqrt.c s_tan.c s_tanh.c
++# extra stuff required for some apps
++CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c
+ CSRC+= s_expm1.c s_scalbn.c s_copysign.c e_acos.c e_asin.c e_atan2.c \
+ k_cos.c e_cosh.c e_exp.c e_fmod.c e_log.c e_log10.c e_pow.c \
+ k_sin.c e_sinh.c e_sqrt.c k_tan.c e_rem_pio2.c k_rem_pio2.c \