summaryrefslogtreecommitdiffstats
path: root/openwrt/target
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-17 10:03:27 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-17 10:03:27 +0000
commitf4252f91aa6b0ec9b467c665c10ad61414636c51 (patch)
treebb2a7845a6567d4dbbff93353731865fa7e39c1b /openwrt/target
parent5b75676da9bd609439c09db82a27543aa598db20 (diff)
another svn-related fix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2116 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/linux/package/openwrt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/target/linux/package/openwrt/Makefile b/openwrt/target/linux/package/openwrt/Makefile
index 82ceb3d90..d1f867351 100644
--- a/openwrt/target/linux/package/openwrt/Makefile
+++ b/openwrt/target/linux/package/openwrt/Makefile
@@ -36,7 +36,7 @@ $(IDIR_OPENWRT):
$(SED) s,base-files-arch,base-files-$(BOARD)-$(KERNEL),g $(IDIR_OPENWRT)/CONTROL/control
$(IPKG_OPENWRT): $(IDIR_OPENWRT)
- [ -d files/$(BOARD)-$(KERNEL) ] && cp -a files/$(BOARD)-$(KERNEL)/* $(IDIR_OPENWRT)/
+ [ -d files/$(BOARD)-$(KERNEL) ] && cp -fpR files/$(BOARD)-$(KERNEL)/* $(IDIR_OPENWRT)/
find $(IDIR_OPENWRT) -name CVS | xargs rm -rf
find $(IDIR_OPENWRT) -name .svn | xargs rm -rf
$(RSTRIP) $(IDIR_OPENWRT)
@@ -47,4 +47,4 @@ install: compile
compile: install-dev $(IPKG_OPENWRT)
install-dev:
mkdir -p $(STAGING_DIR)/usr/include
- cp -a ./include/* $(STAGING_DIR)/usr/include/
+ cp -fpR ./include/[a-z]* $(STAGING_DIR)/usr/include/