summaryrefslogtreecommitdiffstats
path: root/openwrt/target
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-21 03:47:31 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-21 03:47:31 +0000
commite813f121f9fc43c71f43d384731f43e39fda6fd2 (patch)
tree90a29af16f64153723a721be8599c20ece01fd3f /openwrt/target
parent41c1f78fa3aee23b09016ad6b773dfbda6581af5 (diff)
jffs2 root support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@276 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target')
-rw-r--r--openwrt/target/Makefile.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/target/Makefile.in b/openwrt/target/Makefile.in
index 40c9a0578..7a212e489 100644
--- a/openwrt/target/Makefile.in
+++ b/openwrt/target/Makefile.in
@@ -5,8 +5,13 @@ TARGET_SKEL_DIR=target/default/target_skeleton
include target/device/Makefile.in
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+JFFS2FLAGS+=-a 131072
+endif
+
+
$(DIST)-linux.trx: openwrt-trx
- PATH=$(TARGET_PATH) trx -o $(DIST)-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+ PATH=$(TARGET_PATH) trx -o $(DIST)-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(JFFS2FLAGS) $(IMAGE).$(ROOTFS)
$(DIST)-gs-code.bin: openwrt-addpattern $(DIST)-linux.trx
PATH=$(TARGET_PATH) addpattern -2 -i $(DIST)-linux.trx -o $(DIST)-gs-code.bin -g