summaryrefslogtreecommitdiffstats
path: root/openwrt/target/squashfs
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-12 06:12:34 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-12 06:12:34 +0000
commit9b7cc699dfd90235b08dfeb0fe0acb5679bc3b7d (patch)
treecfb62e642bf9597148bdf44222dbdd3d0bb2cb6c /openwrt/target/squashfs
parent3d279d60202200d8e01fadb96f222659a740bae0 (diff)
cleanup the whole addpattern / trx nonsense
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@243 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/squashfs')
-rw-r--r--openwrt/target/squashfs/Config.in2
-rw-r--r--openwrt/target/squashfs/Makefile.in3
-rw-r--r--openwrt/target/squashfs/squashfsroot.mk11
3 files changed, 3 insertions, 13 deletions
diff --git a/openwrt/target/squashfs/Config.in b/openwrt/target/squashfs/Config.in
index a4cb4d8b6..3ef5d2223 100644
--- a/openwrt/target/squashfs/Config.in
+++ b/openwrt/target/squashfs/Config.in
@@ -1,5 +1,5 @@
config BR2_TARGET_ROOTFS_SQUASHFS
- bool "squashfs (ro) root filesystem for the target device"
+ bool "squashfs"
default n
help
Build a squashfs root filesystem
diff --git a/openwrt/target/squashfs/Makefile.in b/openwrt/target/squashfs/Makefile.in
index e3e10066e..14b7f74db 100644
--- a/openwrt/target/squashfs/Makefile.in
+++ b/openwrt/target/squashfs/Makefile.in
@@ -1,3 +1,4 @@
ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
-TARGETS+=squashfsroot openwrt-image-squashfs
+TARGETS+=squashfsroot
+ROOTFS=squashfs
endif
diff --git a/openwrt/target/squashfs/squashfsroot.mk b/openwrt/target/squashfs/squashfsroot.mk
index fce71643f..4dd6800a0 100644
--- a/openwrt/target/squashfs/squashfsroot.mk
+++ b/openwrt/target/squashfs/squashfsroot.mk
@@ -47,14 +47,3 @@ squashfsroot-clean:
squashfsroot-dirclean:
rm -rf $(SQUASHFS_DIR)
-
-openwrt-linux.trx.squashfs:
- $(BUILD_DIR)/trx -o openwrt-linux.trx.squashfs $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).squashfs
-
-openwrt-gs-code.bin.squashfs: openwrt-linux.trx.squashfs
- $(BUILD_DIR)/addpattern -2 -i openwrt-linux.trx.squashfs -o openwrt-gs-code.bin.squashfs -g
-
-openwrt-g-code.bin.squashfs: openwrt-gs-code.bin.squashfs
- sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.squashfs > openwrt-g-code.bin.squashfs
-
-openwrt-image-squashfs: openwrt-g-code.bin.squashfs