summaryrefslogtreecommitdiffstats
path: root/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-04 04:35:15 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-04 04:35:15 +0000
commit22ba317f5174d231be82f368381216404d4032f3 (patch)
treed4618308936a52dfca2e304bfba37bba9b4ca5ec /openwrt/target/squashfs-lzma/squashfslzmaroot.mk
parentdaa2296312f30c1ada9d4c394a785cde8b1fd725 (diff)
fix the jffs2 build for separate 4M/8M images
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@303 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/squashfs-lzma/squashfslzmaroot.mk')
-rw-r--r--openwrt/target/squashfs-lzma/squashfslzmaroot.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
index 722c20524..1aa80e002 100644
--- a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
+++ b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
@@ -39,7 +39,8 @@ squashfslzma-dirclean:
squashfslzmaroot: squashfslzma
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
+ $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma \
+ $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
squashfslzmaroot-source: squashfslzma-source
@@ -52,4 +53,10 @@ squashfslzmaroot-dirclean:
ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS_LZMA)),y)
TARGETS+=squashfslzmaroot openwrt-image
ROOTFS=squashfslzma
+
+openwrt-image: openwrt
+ @make openwrt-code.bin TAG=W54G \
+ EXTRAVERSION=$(EXTRAVERSION)-SQUASHFSLZMA
+ @make openwrt-code.bin TAG=W54S \
+ EXTRAVERSION=$(EXTRAVERSION)-SQUASHFSLZMA
endif