summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-11 13:40:51 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-11 13:40:51 +0000
commit5c4129fd8ca56a98b749315fe70b16347c750e05 (patch)
tree194e311b0694a63a01eaff39054b5b8568e820e0 /openwrt/target/linux
parent75bddef71ae05b51afd36fc9dab9ff9e1b8a3cd2 (diff)
extend mkdep fix (fixes #36)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch b/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
index c1e18a044..a43d1d2fe 100644
--- a/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
+++ b/openwrt/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
@@ -9,3 +9,14 @@
ifdef ALL_SUB_DIRS
$(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)"
endif
+--- linux-2.4.30/Makefile.old 2005-11-11 14:27:55.878482250 +0100
++++ linux-2.4.30/Makefile 2005-11-11 14:28:57.926360000 +0100
+@@ -509,7 +509,7 @@
+ ifdef CONFIG_MODVERSIONS
+ $(MAKE) update-modverfile
+ endif
+- scripts/mkdep -- `find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print` > .hdepend
++ find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print | xargs scripts/mkdep -- > .hdepend
+ scripts/mkdep -- init/*.c > .depend
+
+ ifdef CONFIG_MODVERSIONS