summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/rules.mk
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
commit24dc1f527d33afc44998f5b35a8de368c165f51d (patch)
treea24b15b28fc59486399663b610e84f85d0dd9739 /openwrt/target/linux/rules.mk
parent1c7ecc7b70a5848be016ea82df03a176b0a66636 (diff)
fix 2.6 modules pattern using a common LINUX_KMOD_SUFFIX variable,
fix alsa 2.6 build when arch != mipsel git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2311 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/rules.mk')
-rw-r--r--openwrt/target/linux/rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 2c0fa09c5..f7e108658 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -4,6 +4,11 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/sh[234]/sh/' \
)
+ifeq ($(KERNEL),2.6)
+LINUX_KMOD_SUFFIX=ko
+else
+LINUX_KMOD_SUFFIX=o
+endif
define KMOD_template
ifeq ($$(strip $(4)),)