summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/rules.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-15 10:43:09 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-15 10:43:09 +0000
commit15096df2835b013c4d45d47da4443fa16721e4a9 (patch)
tree64b0e1c80fca3ab7a88ee4a86470d9e79fd61cd1 /openwrt/target/linux/rules.mk
parentbc4db61582edb9dd84c98c0908fdb89d38fe2595 (diff)
add fixes from whiterussian
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1683 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/rules.mk')
-rw-r--r--openwrt/target/linux/rules.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 39afadb34..606efb6d9 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -1,3 +1,10 @@
+LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ -e 's/mipsel/mips/' \
+ -e 's/powerpc/ppc/' \
+ -e 's/sh[234]/sh/' \
+)
+
+
define KMOD_template
ifeq ($$(strip $(4)),)
KDEPEND_$(1):=m
@@ -39,3 +46,5 @@ endif
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)
endef
+
+