summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 00:06:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 00:06:20 +0000
commitc65955aa6a15b044fcdb98b09544536a57a6692c (patch)
treea24ab49da85d53a681590386f6607a72660a29fd /openwrt/target/linux/package
parent9c4caa1e7a14df7eed795618fbd4254a8b09ee4a (diff)
large build system cleanup. added some stuff to control the verbosity level, but not complete, yet.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2221 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package')
-rw-r--r--openwrt/target/linux/package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 7e8588d99..6b7a85816 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -34,20 +34,24 @@ MAKEOPTS:= BOARD="$(BOARD)" \
%-prepare:
+ @$(TRACE) target/linux/package/$(patsubst %-prepare,%,$@)-prepare
$(MAKE) -C $(patsubst %-prepare,%,$@) \
$(MAKEOPTS) \
prepare
%-compile: %-prepare
+ @$(TRACE) target/linux/package/$(patsubst %-compile,%,$@)-compile
$(MAKE) -C $(patsubst %-compile,%,$@) \
$(MAKEOPTS) \
compile
%-install: %-compile
+ @$(TRACE) target/linux/package/$(patsubst %-install,%,$@)-install
$(MAKE) -C $(patsubst %-install,%,$@) \
$(MAKEOPTS) \
install
%-clean:
+ @$(TRACE) target/linux/package/$(patsubst %-clean,%,$@)-clean
@$(MAKE) -C $(patsubst %-clean,%,$@) clean