summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-09 17:16:22 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-09 17:16:22 +0000
commit799f8a41443df3329aaff04d5c3137d5a34f0968 (patch)
treeb890e23775e48be7df439dde674316e1b4039284 /openwrt/target/linux/package
parentb9efbcf7dd49e086ce43823f8ef522883508eddd (diff)
x86-2.6 compile fixes for snapshot build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2867 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package')
-rw-r--r--openwrt/target/linux/package/Makefile2
-rw-r--r--openwrt/target/linux/package/alsa/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index 5fc604d5a..3d28ca77e 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -2,8 +2,10 @@
include $(TOPDIR)/rules.mk
ifneq ($(BOARD),ar7)
+ifneq ($(BOARD)-$(KERNEL),x86-2.6)
package-$(BR2_PACKAGE_KMOD_ALSA) += alsa
endif
+endif
package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
package-$(BR2_PACKAGE_KMOD_HOSTAP) += hostap
package-$(BR2_PACKAGE_KMOD_BCM43XX_DSCAPE) += bcm43xx-dscape
diff --git a/openwrt/target/linux/package/alsa/Makefile b/openwrt/target/linux/package/alsa/Makefile
index eea05a074..02baa44b3 100644
--- a/openwrt/target/linux/package/alsa/Makefile
+++ b/openwrt/target/linux/package/alsa/Makefile
@@ -21,7 +21,7 @@ endif
include $(TOPDIR)/package/rules.mk
ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:=
+KERNEL_C_INCS:= -I$(KERNEL_DIR)/include/asm-i386/mach-generic
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)