summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/wlcompat/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 01:48:39 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 01:48:39 +0000
commit947c8ccd922bd59978a0f625a3fc26cb0fa8e039 (patch)
tree3f1d28a630aa1ed740265fb0db627648351cd655 /openwrt/target/linux/package/wlcompat/Makefile
parent3a6a6bad8bd43b4df5b6e5573fad89851ffb95d2 (diff)
some fixes for wlcompat
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1194 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/wlcompat/Makefile')
-rw-r--r--openwrt/target/linux/package/wlcompat/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/target/linux/package/wlcompat/Makefile b/openwrt/target/linux/package/wlcompat/Makefile
index 777a73164..da905527c 100644
--- a/openwrt/target/linux/package/wlcompat/Makefile
+++ b/openwrt/target/linux/package/wlcompat/Makefile
@@ -26,10 +26,10 @@ $(PKG_BUILD_DIR)/.prepared:
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
touch $@
-$(PKG_BUILD_DIR)/wlcompat.o:
+$(PKG_BUILD_DIR)/wlcompat.o: $(PKG_BUILD_DIR)/.prepared
$(TARGET_CC) $(WLCOMPAT_FLAGS) -o $@ wlcompat.c
-$(PKG_BUILD_DIR)/wlcompat-debug.o:
+$(PKG_BUILD_DIR)/wlcompat-debug.o: $(PKG_BUILD_DIR)/.prepared
$(TARGET_CC) -DDEBUG $(WLCOMPAT_FLAGS) -o $@ wlcompat.c
$(IPKG_KMOD_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o