summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/switch/src
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-12-25 15:15:32 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-12-25 15:15:32 +0000
commit806b93c02793e405da9e25fca0813b2775433bd2 (patch)
tree31694e5e4eaf0fb39e2aafe6d9e676e12133e7ac /openwrt/target/linux/package/switch/src
parent1bf9e140d4d50b841f0bbddd39513df39d156990 (diff)
fix switch driver makefiles for 2.4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2779 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/switch/src')
-rw-r--r--openwrt/target/linux/package/switch/src/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/openwrt/target/linux/package/switch/src/Makefile b/openwrt/target/linux/package/switch/src/Makefile
index dd8a426ec..e4b2b7f38 100644
--- a/openwrt/target/linux/package/switch/src/Makefile
+++ b/openwrt/target/linux/package/switch/src/Makefile
@@ -10,19 +10,9 @@
# 2 of the License, or (at your option) any later version.
#
-KERNEL_VERSION = $(shell uname -r | cut -d. -f1,2)
-
obj-m := switch-core.o switch-adm.o switch-robo.o
+export-objs := switch-core.o
-ifeq ($(KERNEL_VERSION),2.4)
-
-O_TARGET := $(obj-m)
-
+ifeq ($(MAKING_MODULES),1)
-include $(TOPDIR)/Rules.make
-
endif
-
-all: modules
-
-modules:
- $(MAKE) -C $(KERNEL_DIR) SUBDIRS=$(shell pwd) TOPDIR="$(KERNEL_DIR)" modules