summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/openswan
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-28 09:17:29 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-28 09:17:29 +0000
commit50af40000ac37ef921ebd46f6d641959503ee919 (patch)
tree823ff43388135467a5c7a60589acf62d173cedc4 /openwrt/target/linux/package/openswan
parent16530342e5f63527dc2e0c78dcaef4f4b68ceb48 (diff)
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/openswan')
-rw-r--r--openwrt/target/linux/package/openswan/Config.in9
-rw-r--r--openwrt/target/linux/package/openswan/Makefile36
-rw-r--r--openwrt/target/linux/package/openswan/ipkg/kmod-openswan.control6
3 files changed, 51 insertions, 0 deletions
diff --git a/openwrt/target/linux/package/openswan/Config.in b/openwrt/target/linux/package/openswan/Config.in
new file mode 100644
index 000000000..0746197e1
--- /dev/null
+++ b/openwrt/target/linux/package/openswan/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_KMOD_OPENSWAN
+ tristate "kmod-openswan Openswan kernel module"
+ default m if CONFIG_DEVEL
+ help
+ Openswan is an implementation of IPsec for Linux.
+
+ http://www.openswan.org/
+
+ This package contains the Openswan IPSec module for the kernel
diff --git a/openwrt/target/linux/package/openswan/Makefile b/openwrt/target/linux/package/openswan/Makefile
new file mode 100644
index 000000000..5ebb8702d
--- /dev/null
+++ b/openwrt/target/linux/package/openswan/Makefile
@@ -0,0 +1,36 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openswan
+PKG_VERSION:=2.3.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=3dcf1cd7efcbe8db3148fc288d429db1
+
+PKG_SOURCE_URL:=http://www.openswan.org/download
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+include $(TOPDIR)/package/rules.mk
+
+ifeq ($(KERNEL_DIR),)
+KERNEL_DIR:=$(LINUX_DIR)
+endif
+
+$(eval $(call PKG_template,KMOD_OPENSWAN,kmod-openswan,$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+FLAGS := $(TARGET_CFLAGS) -I$(PKG_BUILD_DIR)/linux/include -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ KERNELSRC="$(KERNEL_DIR)" \
+ ARCH="mips" \
+ USERCOMPILE="$(FLAGS)" \
+ module
+
+$(IPKG_KMOD_OPENSWAN):
+ mkdir -p $(IDIR_KMOD_OPENSWAN)/lib/modules/$(LINUX_VERSION)
+ cp $(PKG_BUILD_DIR)/modobj/ipsec.*o $(IDIR_KMOD_OPENSWAN)/lib/modules/$(LINUX_VERSION)/
+ $(IPKG_BUILD) $(IDIR_KMOD_OPENSWAN) $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/package/openswan/ipkg/kmod-openswan.control b/openwrt/target/linux/package/openswan/ipkg/kmod-openswan.control
new file mode 100644
index 000000000..45406e27e
--- /dev/null
+++ b/openwrt/target/linux/package/openswan/ipkg/kmod-openswan.control
@@ -0,0 +1,6 @@
+Package: kmod-openswan
+Section: base
+Priority: optional
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Openswan IPSec kernel module