summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/alsa
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-01 17:30:26 +0000
commit24dc1f527d33afc44998f5b35a8de368c165f51d (patch)
treea24b15b28fc59486399663b610e84f85d0dd9739 /openwrt/target/linux/package/alsa
parent1c7ecc7b70a5848be016ea82df03a176b0a66636 (diff)
fix 2.6 modules pattern using a common LINUX_KMOD_SUFFIX variable,
fix alsa 2.6 build when arch != mipsel git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2311 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/alsa')
-rw-r--r--openwrt/target/linux/package/alsa/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/target/linux/package/alsa/Makefile b/openwrt/target/linux/package/alsa/Makefile
index 7c08d06ca..f616fa077 100644
--- a/openwrt/target/linux/package/alsa/Makefile
+++ b/openwrt/target/linux/package/alsa/Makefile
@@ -43,6 +43,7 @@ $(PKG_BUILD_DIR)/.configured:
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
+ ARCH="$(LINUX_KARCH)" \
c_opts="$(KERNEL_C_OPTS)"
touch $@
@@ -50,6 +51,6 @@ $(IPKG_KMOD_ALSA):
install -d -m0755 $(IDIR_KMOD_ALSA)/etc/modules.d
install -m0644 ./files/alsa.modules $(IDIR_KMOD_ALSA)/etc/modules.d/70-alsa
install -d -m0755 $(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)
- install -m0644 $(PKG_BUILD_DIR)/modules/*.o \
+ install -m0644 $(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX) \
$(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(IDIR_KMOD_ALSA) $(PACKAGE_DIR)