summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-21 11:45:36 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-21 11:45:36 +0000
commitdba6e9388f105f78f3ec6448f6456e9368266a9a (patch)
treec7e4e5abb560ab0ba739d5cb144b6848ff85fcec /openwrt/target/linux/package/Makefile
parentb3c393cfc49f0769e199ddacbce9d726a1408b91 (diff)
move nvram,jffs2root,shared libs into target/linux/package and make them broadcom-specific
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1517 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/package/Makefile')
-rw-r--r--openwrt/target/linux/package/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index f34ad9a8a..adce4d4ee 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -5,10 +5,17 @@ package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
package-$(BR2_PACKAGE_KMOD_MINI_FO) += mini_fo
package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
+
+ifeq ($(BOARD),brcm)
+package-y += nvram openwrt
+
ifeq ($(LINUX_VERSION),2.4.30)
package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
endif
+nvram-compile: openwrt-compile
+endif
+
all: compile install
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
compile: $(patsubst %,%-compile,$(package-y) $(package-m))