summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/linux-2.6/Makefile
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-06 20:13:54 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-06 20:13:54 +0000
commite25ae8b66a401bf8b0acb10311206467f35e7678 (patch)
tree495035a3e6f13b81467821fe96d28a1361efc38c /openwrt/target/linux/linux-2.6/Makefile
parentc9f792c391a3918c5ec36c7014830559c392793f (diff)
Added support for USB ATM devices needed for ueagle-atm
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2848 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/linux-2.6/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.6/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.6/Makefile b/openwrt/target/linux/linux-2.6/Makefile
index d64d7cca0..f961b7c36 100644
--- a/openwrt/target/linux/linux-2.6/Makefile
+++ b/openwrt/target/linux/linux-2.6/Makefile
@@ -58,6 +58,7 @@ include ../netfilter.mk
$(eval $(call KMOD_template,ATM,atm,\
$(MODULES_DIR)/kernel/net/atm/atm.ko \
$(MODULES_DIR)/kernel/net/atm/br2684.ko \
+ $(MODULES_DIR)/kernel/drivers/atm/atmtcp.ko \
,CONFIG_ATM,,50,atm))
$(eval $(call KMOD_template,GRE,gre,\
@@ -376,6 +377,9 @@ $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
$(MODULES_DIR)/kernel/drivers/usb/storage/usb-storage.ko \
,CONFIG_USB_STORAGE,kmod-usb-core,60,scsi_mod sd_mod usb-storage))
+$(eval $(call KMOD_template,USB_ATM,usb-atm,\
+ $(MODULES_DIR)/kernel/drivers/usb/atm/usbatm.ko \
+ ,CONFIG_USB_ATM,kmod-usb-atm,50,usb-atm))
# Misc. devices