summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/linux-2.4
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-23 21:06:51 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-23 21:06:51 +0000
commit55a4a5467553f1dd70fe6455b488d183ee176bf7 (patch)
tree0a45c8f9ca2cf6c354bd2ba7feac92d348eee9b9 /openwrt/target/linux/linux-2.4
parent40c280c75d43bd2738ed650af24a29303e5d1434 (diff)
add -funit-at-a-time in trunk/ as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/linux-2.4')
-rw-r--r--openwrt/target/linux/linux-2.4/patches/generic/006-extra_optimization.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/patches/generic/006-extra_optimization.patch b/openwrt/target/linux/linux-2.4/patches/generic/006-extra_optimization.patch
new file mode 100644
index 000000000..5ae25cbfb
--- /dev/null
+++ b/openwrt/target/linux/linux-2.4/patches/generic/006-extra_optimization.patch
@@ -0,0 +1,24 @@
+--- linux-2.4.30/Makefile 2005-10-23 20:52:56.813948000 +0200
++++ linux.dev/Makefile 2005-10-23 20:53:12.482927250 +0200
+@@ -89,6 +89,8 @@
+ # standard CFLAGS
+ #
+
++check_gcc = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
++
+ CPPFLAGS := -D__KERNEL__ -I$(HPATH)
+
+ CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
+@@ -100,6 +102,12 @@
+ endif
+ AFLAGS := -D__ASSEMBLY__ $(CPPFLAGS)
+
++CFLAGS += $(call check_gcc, -funit-at-a-time,)
++
++
++
++
++
+ #
+ # ROOT_DEV specifies the default root-device when making the image.
+ # This can be either FLOPPY, CURRENT, /dev/xxxx or empty, in which case