summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/imagebuilder
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-19 14:07:32 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-19 14:07:32 +0000
commit35a499ec9f3c64dc7959fc60c1d7e5b45b75e412 (patch)
tree4f58ccffb5d2bdf6a92f51a51d2ed5dd8e2dac58 /openwrt/target/linux/imagebuilder
parentd71b83343a09311cd68798e8cdef9aa24b33d192 (diff)
allow comment lines in the image builder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2533 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/imagebuilder')
-rw-r--r--openwrt/target/linux/imagebuilder/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/openwrt/target/linux/imagebuilder/Makefile b/openwrt/target/linux/imagebuilder/Makefile
index c70fb11e9..0ec71199c 100644
--- a/openwrt/target/linux/imagebuilder/Makefile
+++ b/openwrt/target/linux/imagebuilder/Makefile
@@ -36,7 +36,7 @@ build:
mkdir -p $(LINUX_BUILD_DIR)/root
echo -e 'dest root /\noption offline_root $(LINUX_BUILD_DIR)/root' > $(LINUX_BUILD_DIR)/ipkg.conf
$(IPKG_KERNEL) install $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk
- for package in `cat lists/$(LIST).$(BOARD)-$(KERNEL)`; do \
+ for package in `grep -v '^#' lists/$(LIST).$(BOARD)-$(KERNEL)`; do \
$(IPKG_KERNEL) install `ls packages/$${package}_*`; \
done
if [ -d ./files ]; then \