summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-14 10:23:54 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-14 10:23:54 +0000
commitb14d40272eb178a72870b90d65b953532eccf05d (patch)
tree7edfadeab9f6a1bb05b76aee93d1638515f4b284 /openwrt/target/linux/image
parentc13db991020468cf635db9febf5581d68934d658 (diff)
add preliminary support for the XScale port, generic endianness indication
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/jffs2.mk2
-rw-r--r--openwrt/target/linux/image/squashfs.mk6
-rw-r--r--openwrt/target/linux/image/xscale/Makefile36
3 files changed, 40 insertions, 4 deletions
diff --git a/openwrt/target/linux/image/jffs2.mk b/openwrt/target/linux/image/jffs2.mk
index c7d4335d8..281db0192 100644
--- a/openwrt/target/linux/image/jffs2.mk
+++ b/openwrt/target/linux/image/jffs2.mk
@@ -1,4 +1,4 @@
-ifneq ($(BR2_mips),y)
+ifneq ($(BR2_BIG_ENDIAN),y)
JFFS2OPTS := --pad --little-endian --squash
else
JFFS2OPTS := --pad --big-endian --squash
diff --git a/openwrt/target/linux/image/squashfs.mk b/openwrt/target/linux/image/squashfs.mk
index 0b39aa161..9d344ba5f 100644
--- a/openwrt/target/linux/image/squashfs.mk
+++ b/openwrt/target/linux/image/squashfs.mk
@@ -1,7 +1,7 @@
+ifneq ($(BR2_BIG_ENDIAN),y)
endian := le
-
-ifeq ($(ARCH),mips)
- endian := be
+else
+endian := be
endif
squashfs-prepare:
diff --git a/openwrt/target/linux/image/xscale/Makefile b/openwrt/target/linux/image/xscale/Makefile
new file mode 100644
index 000000000..04a89f9b1
--- /dev/null
+++ b/openwrt/target/linux/image/xscale/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+
+ifeq ($(FS),jffs2-8MB)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
+ $(CP) $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+
+endif
+
+
+ifeq ($(FS),tgz)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
+ $(CP) $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+
+endif
+
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
+ $(CP) $^ $@
+
+
+clean:
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+install-ib:
+ mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
+ $(CP) $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/