summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/aruba/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-16 19:16:51 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-16 19:16:51 +0000
commit5e32cd34edc9d18a447bcf67acb20143fb0211e1 (patch)
tree2fffe0f3eca41a80d51e592aab40de73d46e2744 /openwrt/target/linux/image/aruba/Makefile
parentecb4afc3b8c0ef9b73ed262db5bd9cabb82b44ce (diff)
move natsemi module into the kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2997 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/aruba/Makefile')
-rw-r--r--openwrt/target/linux/image/aruba/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/openwrt/target/linux/image/aruba/Makefile b/openwrt/target/linux/image/aruba/Makefile
index aba11156d..59bf59777 100644
--- a/openwrt/target/linux/image/aruba/Makefile
+++ b/openwrt/target/linux/image/aruba/Makefile
@@ -15,31 +15,18 @@ ifeq ($(IB),)
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).ari: $(KDIR)/vmlinux.lzma
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).ari
-endif
-
-ifeq ($(FS),jffs2-8MB)
-TRXALIGN:=-a 0x20000
-endif
-ifeq ($(FS),jffs2-4MB)
-TRXALIGN:=-a 0x10000
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari: $(KDIR)/vmlinux.lzma
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari
endif
ifeq ($(KERNEL),2.6)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
ifeq ($(FS),jffs2-4MB)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).ari: $(KDIR)/loader.elf
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari: $(KDIR)/loader.elf
./addVersion -n ArubaOS $(KDIR)/loader.elf $@ version
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).ari $(KDIR)/root.$(FS)
- @dd if=$< of=$@.tmp bs=655360 conv=sync
- @cat $(KDIR)/root.$(FS) >> $@.tmp
- @dd if=$@.tmp of=$@ bs=3604480 conv=sync
- @rm -f $@.tmp
-
-install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari
endif
endif