summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/image/aruba/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-20 18:47:42 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-20 18:47:42 +0000
commit24a42b97de7bba205e9a523d064f343a52d42788 (patch)
tree40952c41a911bcd090c0905fd5caff83e74f32ea /openwrt/target/linux/image/aruba/Makefile
parent73913be8bb65d244f3b005b982d2b26ce187318d (diff)
Add a toggle for ramdisk support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3030 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/aruba/Makefile')
-rw-r--r--openwrt/target/linux/image/aruba/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/aruba/Makefile b/openwrt/target/linux/image/aruba/Makefile
index 59bf59777..432a85d59 100644
--- a/openwrt/target/linux/image/aruba/Makefile
+++ b/openwrt/target/linux/image/aruba/Makefile
@@ -26,6 +26,16 @@ ifeq ($(FS),jffs2-4MB)
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari: $(KDIR)/loader.elf
./addVersion -n ArubaOS $(KDIR)/loader.elf $@ version
+ifneq ($(BR2_ARUBA_RAMDISK),y)
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari $(KDIR)/root.$(FS)
+ @dd if=$< of=$@.tmp bs=655360 conv=sync
+ @cat $(KDIR)/root.$(FS) >> $@.tmp
+ @dd if=$@.tmp of=$@ bs=3604480 conv=sync
+ @rm -f $@.tmp
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
+endif
+
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari
endif
endif