summaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-14 10:23:54 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-14 10:23:54 +0000
commitb14d40272eb178a72870b90d65b953532eccf05d (patch)
tree7edfadeab9f6a1bb05b76aee93d1638515f4b284 /openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch
parentc13db991020468cf635db9febf5581d68934d658 (diff)
add preliminary support for the XScale port, generic endianness indication
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch')
-rw-r--r--openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch b/openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch
index 91da40ac3..21d09b6f0 100644
--- a/openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch
+++ b/openwrt/target/linux/generic-2.6/patches/005-gcc4_fix.patch
@@ -183,3 +183,15 @@ diff -Nur linux-2.6.15.1/lib/Makefile linux-2.6.15.1-openwrt/lib/Makefile
obj-y += sort.o parser.o halfmd4.o
+diff -Nur linux-2.6.15.1/include/asm-arm/libgcc.h linux-2.6.15.1-openwrt/include/asm-arm/libgcc.h
+--- linux-2.6.15.1/include/asm-arm/libgcc.h 1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.15.1-openwrt/include/asm-arm/libgcc.h 2006-04-12 23:01:18.000000000 +0200
+@@ -0,0 +1,8 @@
++#ifndef __ASM_LIBGCC_H
++#define __ASM_LIBGCC_H
++
++#undef ARCH_NEEDS_ashldi3
++#undef ARCH_NEEDS_ashrdi3
++#undef ARCH_NEEDS_lshrdi3
++
++#endif /* __ASM_LIBGCC_H */