summaryrefslogtreecommitdiffstats
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 09:08:38 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 09:08:38 +0000
commite8d897309949d4c2cc7a77ba0e6ca84f071fa6e9 (patch)
tree66a9a28ea0c69b059939becc0f335bc8ec1d5437 /openwrt/target/Makefile
parent75821f0878d074fff9467e4c74d2ed718a35002f (diff)
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index 6a1bd954a..437609a28 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -73,6 +73,7 @@ $(BIN_DIR):
mkdir -p $(BIN_DIR)
$(INSTALL_TARGET_DIRS): lzma-loader-compile
+$(IMAGE_TARGETS): $(patsubst %,%-install,$(TARGET_DIRS))
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean