summaryrefslogtreecommitdiffstats
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 00:06:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-10-22 00:06:20 +0000
commitc65955aa6a15b044fcdb98b09544536a57a6692c (patch)
treea24ab49da85d53a681590386f6607a72660a29fd /openwrt/target/Makefile
parent9c4caa1e7a14df7eed795618fbd4254a8b09ee4a (diff)
large build system cleanup. added some stuff to control the verbosity level, but not complete, yet.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2221 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index e6156b48b..a14749fca 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -17,15 +17,21 @@ image_clean:
rm -f $(BIN_DIR)/openwrt-*
%-clean:
+ @$(TRACE) target/$(patsubst %-clean,%,$@)/clean
$(MAKE) -C $(patsubst %-clean,%,$@) clean
%-prepare:
+ @$(TRACE) target/$(patsubst %-prepare,%,$@)/prepare
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare
%-compile: %-prepare
+ @$(TRACE) target/$(patsubst %-compile,%,$@)/compile
$(MAKE) -C $(patsubst %-compile,%,$@) compile
%-rebuild:
+ @$(TRACE) target/$(patsubst %-rebuild,%,$@)/rebuild
$(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
%-install: %-compile
+ @$(TRACE) target/$(patsubst %-install,%,$@)/install
$(MAKE) -C $(patsubst %-install,%,$@) install
linux-imagebuilder:
+ @$(TRACE) target/linux/imagebuilder
$(MAKE) -C linux imagebuilder