summaryrefslogtreecommitdiffstats
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 12:12:58 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 12:12:58 +0000
commit2b9b4c5a2de2c0a12e2d96c0c9b65aa5b0c2ab2f (patch)
tree055a93ec854a535cea0fb03637e40e82661918d7 /openwrt/target/Makefile
parentaf421d122f149f9d7b28e01f0f21496e4df225d4 (diff)
lzma loader patch from oleg, great thanks good work, saves another 300 kb flashmemory
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@513 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index a17a80ffc..c8baab5f7 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -29,6 +29,20 @@ IMAGE_TARGETS += $(BIN_DIR)/openwrt-motorola-$(1).bin
endif
endef
+# Enable loader and prepare kernel
+ifeq ($(strip $(BR2_PACKAGE_LOADER)),y)
+export LINUX_LOADER=$(BUILD_DIR)/lzmaldr
+export LINUX_IMAGE=$(BUILD_DIR)/piggy.lzma
+else
+export LINUX_IMAGE=$(BUILD_DIR)/piggy.gz
+endif
+
+$(BUILD_DIR)/piggy.lzma: $(LINUX_KERNEL)
+ cat $^ | $(BUILD_DIR)/lzma/lzma e -si -so -eos > $@ || (rm -f $@ && false)
+
+$(BUILD_DIR)/piggy.gz: $(LINUX_KERNEL)
+ cat $^ | gzip -c9 $^ > $@ || (rm -f $@ && false)
+
TARGET_DIRS:=
TARGET_FS:=
IMAGE_TARGETS:=
@@ -70,7 +84,7 @@ $(BIN_DIR):
mkdir -p $(BIN_DIR)
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
-install: utils-install $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
+install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean
image_clean: