summaryrefslogtreecommitdiffstats
path: root/openwrt/target/Makefile.in
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 07:46:01 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 07:46:01 +0000
commitdb7f4ab4d2a1c5d385bacf2c695b796d81f7c912 (patch)
treefc4b24d257d49bf1fa37f482d183fe7e79ff4457 /openwrt/target/Makefile.in
parentd66efda5367272e0e48dfaec2b00964c42400319 (diff)
sync with buildroot2 from uclibc, add devices, may be used to build other kernel modules for different devices, can be used for other stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@267 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/Makefile.in')
-rw-r--r--openwrt/target/Makefile.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/openwrt/target/Makefile.in b/openwrt/target/Makefile.in
index c01ade299..802b576fb 100644
--- a/openwrt/target/Makefile.in
+++ b/openwrt/target/Makefile.in
@@ -1 +1,17 @@
-# Nothing
+# Default target skeleton stuff, may be overridden
+TARGET_SKELETON=target/default/skel.tar.gz
+TARGET_SKEL_DIR=target/default/target_skeleton
+
+include target/device/Makefile.in
+
+openwrt-linux.trx: openwrt-trx
+ PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+ PATH=$(TARGET_PATH) addpattern -2 -i openwrt-linux.trx -o openwrt-gs-code.bin -g
+
+openwrt-g-code.bin: openwrt-gs-code.bin
+ sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+
+openwrt-image: openwrt-g-code.bin
+