summaryrefslogtreecommitdiffstats
path: root/openwrt/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-08 20:21:36 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-08 20:21:36 +0000
commitd03bbf6ccf1115df553a1712e57864ac686c3ee9 (patch)
tree6dc4010bbf4b4c5c8f1a18bfa766c25c3d8e1699 /openwrt/package
parent0dcecf3d89b774c13f7c985db7ce049636c515b8 (diff)
fix kismet-server and add mostlyclean target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1177 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/kismet/Makefile3
-rw-r--r--openwrt/package/kismet/patches/110-uclibc++_fixes.patch12
2 files changed, 15 insertions, 0 deletions
diff --git a/openwrt/package/kismet/Makefile b/openwrt/package/kismet/Makefile
index 0ae6b5e24..971c40e73 100644
--- a/openwrt/package/kismet/Makefile
+++ b/openwrt/package/kismet/Makefile
@@ -88,3 +88,6 @@ $(IPKG_KISMET_SERVER):
$(RSTRIP) $(IDIR_KISMET_SERVER)
$(IPKG_BUILD) $(IDIR_KISMET_SERVER) $(PACKAGE_DIR)
+mostlyclean:
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/kismet/patches/110-uclibc++_fixes.patch b/openwrt/package/kismet/patches/110-uclibc++_fixes.patch
index 4cf5a7b5b..66fc77e07 100644
--- a/openwrt/package/kismet/patches/110-uclibc++_fixes.patch
+++ b/openwrt/package/kismet/patches/110-uclibc++_fixes.patch
@@ -27,3 +27,15 @@ diff -urN kismet-2005-04-R1.old/macaddr.h kismet-2005-04-R1.dev/macaddr.h
return (singleton_itr != op.singleton_itr) || (vector_itr != op.vector_itr);
}
+diff -urN kismet-2005-04-R1.old/tcpserver.cc kismet-2005-04-R1.dev/tcpserver.cc
+--- kismet-2005-04-R1.old/tcpserver.cc 2005-04-03 07:33:42.000000000 +0200
++++ kismet-2005-04-R1.dev/tcpserver.cc 2005-06-08 23:17:34.000000000 +0200
+@@ -373,7 +373,7 @@
+ return 0;
+ }
+ } else {
+- copt->wrbuf.erase(0, res);
++ copt->wrbuf = "";
+ }
+ }
+