summaryrefslogtreecommitdiffstats
path: root/openwrt/package/vsftpd
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 21:30:44 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 21:30:44 +0000
commitdb6df8cc830123e680e41b5e104cd217b03b1edf (patch)
treee3cdb4d7412c1e3fcfceda877756f53f3d68a157 /openwrt/package/vsftpd
parent3aceccdf76ed970aab0dcbfafacf6fad4d056c73 (diff)
Tweak package build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@978 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/vsftpd')
-rw-r--r--openwrt/package/vsftpd/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/openwrt/package/vsftpd/Makefile b/openwrt/package/vsftpd/Makefile
index a8b32f1e8..1801d808c 100644
--- a/openwrt/package/vsftpd/Makefile
+++ b/openwrt/package/vsftpd/Makefile
@@ -19,17 +19,17 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,VSFTPD,vsftpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)"
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ vsftpd install
+ touch $@
$(IPKG_VSFTPD):
install -d -m0755 $(IDIR_VSFTPD)/etc