summaryrefslogtreecommitdiffstats
path: root/openwrt/package/vrrpd/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/vrrpd/Makefile
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/vrrpd/Makefile')
-rw-r--r--openwrt/package/vrrpd/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/openwrt/package/vrrpd/Makefile b/openwrt/package/vrrpd/Makefile
deleted file mode 100644
index 8805450c6..000000000
--- a/openwrt/package/vrrpd/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vrrpd
-PKG_VERSION:=1.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
-
-PKG_SOURCE_URL:=@SF/vrrpd
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,VRRPD,vrrpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- DBG_OPT="" \
- MAIN_OPT="$(TARGET_CFLAGS)" \
- vrrpd
- touch $@
-
-$(IPKG_VRRPD):
- install -d -m0755 $(IDIR_VRRPD)/etc/default
- install -m0644 ./files/vrrpd.default $(IDIR_VRRPD)/etc/default/vrrpd
- install -d -m0755 $(IDIR_VRRPD)/etc/init.d
- install -m0755 ./files/vrrpd.init $(IDIR_VRRPD)/etc/init.d/vrrpd
- install -d -m0755 $(IDIR_VRRPD)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/vrrpd $(IDIR_VRRPD)/usr/sbin/
- $(RSTRIP) $(IDIR_VRRPD)
- $(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)